架构师_程序员

 找回密码
 注册[Register]

QQ登录

只需一步,快速开始

查看: 100|回复: 2

[linux] openssl明明已经更新了,apache还是提示使用的旧版?

[复制链接]
跳转到指定楼层
楼主
发表于 2019-7-4 09:26:14
zu
提示说apache重启失败,日志里是openssl版本过旧,我更新了openssl,但是新的日志还是说用的是旧版openssl怎么破?
[Mon Jul 01 01:13:34.416869 2019] [ssl:warn] [pid 6475:tid 140085385488192] AH01882: Init: this version of mod_ssl was compiled against a newer library (OpenSSL 1.0.2r 26 Feb 2019, version currently loaded is OpenSSL 1.0.2n 7 Dec 2017) - may result in undefined or erroneous behavior
[Mon Jul 01 01:13:34.465058 2019] [ssl:warn] [pid 6476:tid 140085385488192] AH01882: Init: this version of mod_ssl was compiled against a newer library (OpenSSL 1.0.2r 26 Feb 2019, version currently loaded is OpenSSL 1.0.2n 7 Dec 2017) - may result in undefined or erroneous behavior




上一篇:.net/c# 用户多线程并发lock(string){...}详解
下一篇:Google Chrome 将于7月9日起在全球范围内支持优质广告标准
帖子永久地址: 

架构师_程序员 - 论坛版权1、本主题所有言论和图片纯属会员个人意见,与本论坛立场无关
2、本站所有主题由该帖子作者发表,该帖子作者与架构师_程序员享有帖子相关版权
3、其他单位或个人使用、转载或引用本文时必须同时征得该帖子作者和架构师_程序员的同意
4、帖子作者须承担一切因本文发表而直接或间接导致的民事或刑事法律责任
5、本帖部分内容转载自其它媒体,但并不代表本站赞同其观点和对其真实性负责
6、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意
7、架构师_程序员管理员和版主有权不事先通知发贴者而删除本文

码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
沙发
发表于 2019-7-4 10:05:47
是不是需要更新一下配置

  1. LoadModule ssl_module modules/mod_ssl.so
复制代码


覆盖mod_ssl.so文件,记得备份
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
板凳
 楼主| 发表于 2019-7-9 15:00:30
小渣渣 发表于 2019-7-4 10:05
是不是需要更新一下配置

怎么更新mod_ssl.so呢?打开它看是一堆乱码……
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
您需要登录后才可以回帖 登录 | 注册[Register]

本版积分规则

免责声明:
码农网所发布的一切软件、编程资料或者文章仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。如果您喜欢该程序,请支持正版软件,购买注册,得到更好的正版服务。

Mail To:help@itsvse.com

QQ|Archiver|手机版|小黑屋|架构师 ( 鲁ICP备14021824号-2 )|网站地图

GMT+8, 2019-7-22 05:04

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表