架构师_程序员

 找回密码
 注册[Register]

QQ登录

只需一步,快速开始

查看: 1186|回复: 8

[易语言] 枪神纪游戏开源 交流

[复制链接]
发表于 2019-6-15 18:21:22 | 显示全部楼层
开源  觉得有用可以自己学习  编译绝对能用! 骗子死全家  怕有远控的 大佬自己查看 源码提供学习!
.版本 2

                    .如果真 (子弹聚集)
                        内存操作.写整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (#基地址) + 1188)) + 64) + 972) + 1032) + 1376, -30)
                        内存操作.写整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (#基地址) + 1188)) + 64) + 972) + 1032) + 1416, 0)



360°自动背刺
.版本 2

                        .如果真 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (#基地址 + 192) + 24) + 184) + 972) + 184) ≠ 0)
                            .如果真 (本人的数据.团队 ≠ 玩家团队)
                                写_DWORD2 (Target + 128, 读_DWORD2 (本人的数据.my_Pawn + 128))  ' 写敌人坐标面像自己坐标
                                内存操作.写整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (#基地址) + 1188)) + 64) + 972) + 1032) + 3388) + 624, 0)
                                .如果真 (内存操作.读整数 (内存操作.读整数 (本人的数据.my_Pawn + #职业1级) + #职业2级) = #刀锋职业ID 且 到整数 (读_float2 (本人的数据.my_Pawn + #血量)) > 0)
                                    .如果 (内存操作.读整数 (内存操作.读整数 (本人的数据.武器基址 + 3388) + 508) ≠ 0)
                                        内存操作.写小数 (本人的数据.局部人物基址 + 1660, 0.0001)
                                        mouse_event (2, 0, 0, 0, 0)
                                        mouse_event (4, 0, 0, 0, 0)


.版本 2
.支持库 eAPI

                    .如果真 (无限制跳)
                        .如果真 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (#基地址) + 192) + 24) + 184) + 972) + 184) ≠ 0)  ' 这个是死亡判断
                            连跳基质 = 内存操作.读整数 (#基地址)
                            连跳基质 = 内存操作.读整数 (连跳基质 + 1188)
                            连跳基质 = 内存操作.读整数 (连跳基质)  ' 0
                            连跳基质 = 内存操作.读整数 (连跳基质 + 64)
                            连跳基质 = 内存操作.读整数 (连跳基质 + 972)

                            写_DWORD2 (本人的数据.my_Pawn + #无限跳, 1)
                            .如果 (MY_GetAsyncKeyState (#Shift键) < 0)
                                内存操作.写整数 (连跳基质 + 176, 100795137)
                                模拟按键 (#Shift键, , )
                                模拟按键 (#Shift键, , )
                                内存操作.写整数 (连跳基质 + 176, 100795137)
                                模拟按键 (#Shift键, , )
                                模拟按键 (#Shift键, , )
                                内存操作.写整数 (连跳基质 + 176, 100795137)
                                模拟按键 (#Shift键, , )
                                模拟按键 (#Shift键, , )

.版本 2

.子程序 DrawAimBox, 自瞄坐标
.参数 自己坐标, D3D坐标
.参数 pawn, 整数型
.参数 fov, 小数型
.参数 cam, FRotator
.参数 hdc, 整数型, 可空
.参数 颜色, 整数型, 可空
.参数 mypawn, 整数型, 可空
.参数 PlayerController, 整数型, 可空
.参数 线宽, 整数型
.参数 是否显示, 逻辑型, 可空
.局部变量 中心宽度, 整数型
.局部变量 中心高度, 整数型
.局部变量 自瞄X, 整数型
.局部变量 自瞄Y, 整数型
.局部变量 自瞄W, 整数型
.局部变量 自瞄H, 整数型
.局部变量 Device_Interface, 整数型
.局部变量 Mycharacterjz, 整数型
.局部变量 Mycharacter, 整数型
.局部变量 背刺我的人物的基址, 整数型
.局部变量 背刺我的人物地址, 整数型
.局部变量 背刺我的人物的基址2, 整数型
.局部变量 背刺我的人物的基址3, 整数型
.局部变量 背刺我的人物的基址4, 整数型
.局部变量 背刺我的人物的基址5, 整数型
.局部变量 背刺我的人物基址, 整数型
.局部变量 Mycharacterjz2, 整数型
.局部变量 Mycharacterjz3, 整数型
.局部变量 Mycharacterjz4, 整数型
.局部变量 Mycharacterjz5, 整数型
.局部变量 Backstabbase, 整数型
.局部变量 Remotetool, 整数型
.局部变量 Automaticbackstab, 整数型
.局部变量 敌人相对距离, 自瞄坐标

A = WorldToScreen (自己坐标, 取FVector (pawn + #pawn_FVector), fov, cam, pawn, hdc)
敌人相对距离.d = A.d
.如果真 (判断距离)
    .如果 (A.d ÷ 10 < 3 且 读_DWORD2 (读_DWORD2 (本人的数据.my_Pawn + #职业1) + #职业2) = #刀锋职业ID)
        正面背刺= 真
    .否则
        正面背刺 = 假
    .如果结束

.如果真结束

返回 (敌人相对距离)

距离判断背刺  

需要功能的给我留言我在开给大家 学习交流!
4.png 3.png 2.png 1.png

下载:

游客,如果您要查看本帖隐藏内容请回复







上一篇:百度云下载限速,pandown就不限速了,普遍在18M/s
下一篇:收集了完整的《神经网络与深度学习》共500多G
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
发表于 2019-6-15 19:17:32 | 显示全部楼层
到底是c 还是易语言?
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
发表于 2019-6-17 09:11:05 | 显示全部楼层
夏天 发表于 2019-6-15 19:17
到底是c 还是易语言?

易语言源码
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
发表于 2019-7-21 23:51:50 | 显示全部楼层
没有源码了吗???
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
发表于 2019-8-16 08:03:36 | 显示全部楼层
感谢分享
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
发表于 2019-8-30 22:51:40 | 显示全部楼层
感谢分享
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
发表于 2019-12-18 17:02:02 | 显示全部楼层
?????????就是不知道需要多少MB
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
发表于 2020-1-31 00:01:08 | 显示全部楼层
让我东赞歌看看这东西
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
发表于 2020-2-6 09:00:34 | 显示全部楼层
大佬顶大佬顶大佬顶大佬顶大佬顶大佬顶大佬顶大佬顶大佬顶大佬顶大佬顶
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
您需要登录后才可以回帖 登录 | 注册[Register]

本版积分规则

免责声明:
码农网所发布的一切软件、编程资料或者文章仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。如果您喜欢该程序,请支持正版软件,购买注册,得到更好的正版服务。如有侵权请邮件与我们联系处理。

Mail To:help@itsvse.com

QQ|Archiver|手机版|小黑屋|架构师 ( 鲁ICP备14021824号-2 )|网站地图

GMT+8, 2020-7-8 21:30

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表