架构师_程序员_码农网

 找回密码
 注册[Register]

QQ登录

只需一步,快速开始

查看: 79|回复: 0

【实战】CentOS 安装 zlib-1.2.9 包

[复制链接]
发表于 2022-1-13 15:47:13 | 显示全部楼层
在使用 npm install 命令,还原下载前端需要的模块的时候,报错如下:

QQ截图20220113151416.jpg

Command failed: /data/jenkins/workspace/web-demo-mobile/node_modules/mozjpeg/vendor/cjpeg -version
/data/jenkins/workspace/web-demo-mobile/node_modules/mozjpeg/vendor/cjpeg: /lib64/libz.so.1: version `ZLIB_1.2.9' not found (required by /data/jenkins/workspace/web-demo-mobile/node_modules/mozjpeg/vendor/cjpeg)
报错提示表明在 /lib64/libz.so.1 中缺少 ZLIB_1.2.9 或更高版本,系统安装的是:1.2.7 版本,解决方案是安装 zlib-1.2.9。

QQ截图20220113152232.jpg

zlib 所有版本:http://www.zlib.net/fossils/


下载 zlib 1.2.9 进行编译安装,命令如下:

将 libz.so.1.2.9 复制到 /lib64/ 文件夹,命令如下:

创建软链接,命令如下:

QQ截图20220113153756.jpg

(完)




上一篇:Spring jackson-dataformat-xml 设置接口默认返回 JSON 格式
下一篇:【转】Ubuntu、CentOS、RedHat 的区别与联系
码农网,只发表在实践过程中,遇到的技术难题,不误导他人。
您需要登录后才可以回帖 登录 | 注册[Register]

本版积分规则

免责声明:
码农网所发布的一切软件、编程资料或者文章仅限用于学习和研究目的;不得将上述内容用于商业或者非法用途,否则,一切后果请用户自负。本站信息来自网络,版权争议与本站无关。您必须在下载后的24个小时之内,从您的电脑中彻底删除上述内容。如果您喜欢该程序,请支持正版软件,购买注册,得到更好的正版服务。如有侵权请邮件与我们联系处理。

Mail To:help@itsvse.com

QQ|手机版|小黑屋|架构师 ( 鲁ICP备14021824号-2 )|网站地图

GMT+8, 2022-1-29 06:30

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表